Beta Feature - Serial Output

Today we’re releasing a beta beta build that includes serial output. Please use this thread to post any questions or feedback.

I have a generic stratux can I use flight box softwear and serial adapter to communicate with my GRT

I installed the Serial USB Output cable tonight and attached to Garmin Aera 796 with the hopes to get Traffic and possibly weather displayed. I played with the setup of the Garmin as several data format options but none that indicated data was being recieved. Anyone having success with Garmin interfacing with FlightBox? If so, how are you setting up?

I don’t think you’ll have any luck getting it to work with Garmin gear. They use a proprietary handshake process to prevent anything other than their own GDL-39 receivers and their panel-mount gear from talking to the Aera series and the Pilot app.

Yes, it should work without any problems. You’ll need an available USB port on your Stratux.

Guess I should have asked before I purchased the cable. Any plans to work around the handshake issue? The 796 also has Bluetooth in capability, would similar handshake be an issue with BT?

You’ll have the same issue regardless of the interface - wired, Bluetooth, or Wifi. Garmin is very proprietary - they have their own closed ecosystem and they don’t really seem to have much interest in allowing anyone else to play - at least not without either paying quite a bit or owning a huge chunk of market share. Their Pilot app one of only two EFB apps that we’re not able to interact with (the other is Jeppesen Mobile FliteDeck).

I could use some help with this Serial Output project from those that have had success hooking up to their EFIS.

I have an rP3 with 1090 and 978 SDRs with remote 1/2 wave antennae, an external GPS module, and the USB-serial cable from OFS. I’m running the Beta image file (ver 1.1b1) on my SD card. On the UI, I see tons of 1090 and 978 traffic (real and, I believe a few simulated) and have lock on at least 10 GPS satellites. Prior to this, I’ve run iFly over the Wifi adapter, and it worked fine. However, when I hook up the USB-serial cable, no joy.

For the USB-serial project, I’ve tried two devices to serve as my ‘EFIS’ . Neither has been able to see GPS data. One is a Naviter Oudie, a small PDA-like flight computer, which accepts external GPS and traffic (NMEA) data to a designated COM port, and the other is a Windows PC, running XCSoar, which does the same. For the Oudie, I patch directly to the rP3 thru the USB-serial cable. For the PC, I must connect the USB-serial from the rP3 thru another USB-serial cable to the the PC.

I know that I’m getting good connections, as both programs have a terminal feature that displays what is coming thru the COM ports. Both configurations display streams of characters interspersed with the flight numbers of many of the aircraft displayed on the UI. I think this means I’m getting ADS-B data, but no GPS thru the cable, as these devices cannot get a location fix on themselves or other traffic. It doesn’t seem to matter what baud rates I choose, as long as the Flightbox and EFIS COM port speeds match. It doesn’t seem to matter what ports I plug the GPS or USB-serial cables into on the rP3, nor does it help to use a powered USB for either device.

There was mention of a conflict between the USB-serial and GPS, but this was handled by designating unique identifiers to these devices. I’m not sure if there is an existing conflict between the USB and GPS, but am open to any ideas as how to troubleshoot his possibility.


Had a hardware problem; apparently my wires were mis-ordered and it’s the yellow one, not the orange one, that’s giving serial output.

Now I appear to be up and running; at least, I have what looks like GDL-90 strings in my terminal program.

Next question: how do I slow down the serial output from 38400 baud to the 19200 that’s needed by my MGL EFIS?

Silly me. It’s not 19200, it’s 115200, and it works just fine even at that speed, thanks. Serial ADS-B into an MGL; finally! Thanks!

1 Like

I went a little different route because I ran out of serial inputs in my GRT.

I added a DB9 connector to the side of the case, and a 5V regulator inside the box so I could just treat it like an avionics device and give it 12Volts. Using the GPIO header, I used the serial output (changed the code) which goes to an USB->TTL cable. With GRT, it accepts ADBS-In through USB.

I have an ack e-04 elt which allows gps inputs from “portable” gps units. It requires a NMEA 0183 input at baud rates of either 1200, 2400, 4800, or 9600. The input is only one pin on a rs 232 connector. Will your adapter cable listed above work for this? Can the baud rate be slowed all the way down to 9600 via the procedure listed above in the settings?

BTW, just returned from a 1 week CC trip using my brand new flightbox with remote mount ads-b antennas/remote Gps/AHRS coupled to an Ipad mini/foreflight moving map & iphone 6 plus in guardian mount running wingx pro synthetic vision. Initially the AHRS was a bit unreliable, but after switching to 3m mounting tape with interlocking fingers vice velcro, AHRS was rock steady for almost 40 hours of flight time.


The RS232 cable we’re offering at this point only outputs GDL-90, the transport protocol used to send ADS-B information to display hardware. I’ve already got NMEA out for autopilots on the feature list, and I think that would cover your use case as well. It won’t be particularly difficult to add support for output of NMEA data using the same hardware. Given the limited number of exposed USB ports on the Pi you might have to add a simple unpowered USB 2.0 hub if you ever wanted to have a second output to send GDL-90 to an EFIS. You would need to fabricate the DIN connector to interface it with the ELT. The ACK manual makes that look relatively simple.

Please check back with me a bit later in the summer and I’ll send you a beta to test out.



Has this go back a bit in time, is NMEA being output now in version 1.4R5??? I’ve connected the serial to my EZ-Pilot and it’s not being seen, Got my Garmin-296 connected to the AP and as soon as I have enought satellite locked-In, the AP is getting info. I Know the Garmin 296 is outputting NMEA-0183 and the AP is also expecting that protocol… Could it be that the stratux is not outputing NMEA-0183 format?? and outputing another format???

A couple of thoughts on this:

  1. We offer two serial output cables: one for ADS-B (GDL-90) and another for NMEA. Be sure you have the NMEA cable and not the ADS-B cable.

  2. When you connect the serial output cable to the USB jack, the FlightBox will automatically detect it and start sending data at a default baud rate. This may not be the baud rate the equipment at the far end of the cable expects. You can adjust the baud rate from the Setting page in the web interface.

  3. The NMEA output will only happen when the FlightBox’s GPS has a solid fix. Make sure that the GPS is showing a 3D fix before testing the NMEA cable.

  4. I’ve recently tested the new v2.0r1 for NMEA output and I know that it works correctly. If you’re not getting anything with 1.4r5 (which you should) please try installing v2. You can do so using the FlightBox Utility app or manually using this file.

  1. Have the NMEA cable you recently sent me
  2. Both have 4800BPS, my EZ Pilot is expecting 4800 and my setting in Web interface is 4800
  3. GPS is showing 12 in solution, is this good enought for 3D???

Depending on your answer of 3, I will see if i’ll go with V2.
on the status page I see GPS data with a round button with a dot in the middle(green)

That all looks correct. I wonder if the EZ-Pilot needs output beyond the two NMEA sentences we’re currently sending ($GPRMB, $GPGGA). Those are all that are required for basic Track function on a TruTrak, and a Dynon. I can’t find anything in the EZ-Pilot manual that indicates which NMEA-0183 sentences are required. Do you have any info from Trio?

Other than the manual I don’t but I will ask them and be back to you.

On another track some option that I see referenced like the device tab/log switch and a few other
makes me wonder If I have the right 1.4R5???

Can you point me to an image or update link that could of been done to the original
version that was particular to the stratux… Thx

Trio just responded me… GPRMB GPRMC

Hrm… We do output $GPRMC once per second. That sentence includes the current location, ground speed, and ground track. It should be enough to allow the EZ-Pilot to operate in Track mode.

The $GPRMB message is the lateral deviation and bearing to next waypoint message that is typically used by the autopilot in NAV mode. We don’t have a way to output that message as we don’t have any course information.

(We do output this message in our new FlightView EFIS, but that requires the full stack including our app and the FlightBox Pro EXP.)

You can download the update for 1.4r5 from here:

Thx for the update… I’m now having issues with WIFI, can’t see the Stratux ???:smirk: