Updating firmware

Hi there, not sure if anyone else is having an issue, but I just downloaded the app so that I can update the firmware of my flightbox from v0.8r2 too the new version but the “Update Firmware” command is not selectable. I’m using the app on my iPhone so that I have cellular data and WiFi, thinking that my WiFi-only iPad couldn’t download the update when it was connected to the box. Regardless, it seems to make no different. It’s there something that I am missing? Thanks!


Never mind, disregard. It seems that maybe I just didn’t wait long enough. It is fine now.

Ah, good. It does take a few seconds to download the firmware file before you can go “offline” and update the FlightBox.

Easy as saved file on desktop reconnected to Flightbox and Bobs your uncle, lots new buttons to slide, thanks.

FYI using the external antenna I am seeing adsb out to 150 sometimes 200 nM 500 km. At altitude. Interesting new pages in the Traffic Tab.

Anyway of accessing and enlarging the map on gps location page?

Excellent have list of all the satellites it has locked on with, keep up the good developments.

8 m accuracy 20 feet.

I tried the update via the ipad after downloading the utility and the ipad said there is a update available but the “Update Firmware” is ghosted. Tried the old way with the IP address and it will not connect. It worked on the previous version when updating. Have not gotten the unit to show any targets, so maybe its just plain dead in the first place.

The “Update Firmware” button would be grayed out for one of two reasons - either the firmware was not downloaded to the iPad or the FlightBox was not running a compatible version of the software. Try this:

Connect the iPad to a wifi network that is connected to the Internet. Open the app and give it at least 30 seconds to download the firmware from our servers.

Next, fire up the FlightBox, connect the iPad to the FlightBox wifi network. Then re-open the app. If it still shows the “Update Firmware” button grayed-out, kill it (double tap home button, slide the app up) and restart it. The button should be enabled. If not, let me know and we can do some further diagnostics.

I’m having the same problem with updating the firmware. Tried everything recommended in this thread, but the Update Firmware option is still not available.

I had the same experience. Ghosted “Update firmware” button on the app on my iPhone. I waited a minute or two. If it takes longer than this, you might consider mentioning it in the instructions to avoid a bunch of reports like these. I just updated using the older method on my laptop and everything was smooth as silk. Thanks for making this device available and all your hard work on it!

Do you have green lights on “Wifi Network” and “Data Connection” on the Status page?

I did. Yes. My phone was connected to the flightbox via wifi and all systems were go, as they say. Went to “Settings” and saw the button to update firmware, but it wouldn’t activate.

Wifi and Data were green. UATs were yellow. GPS and AHRS were gray (I was on the ground and indoors). I got a notification to update firmware. Then when I selected “Settings” in the lower right, the button for updating on the next screen was gray and inop.

Edited to add: I used the “reboot” function in the app to reboot my device and see if it would make a difference. It did reboot my device, but didn’t help with the problem.

Did you try killing and re-starting the iOS app?

Yes, I did. No change. (and to clarify, I’ve since made the update via my laptop, so I’m good to go. Just letting you know the app didn’t work for me).

Thanks. And very strange. I’ll have to do some more testing and see if I can figure out what’s up.

Yes, both lights are green. The unit is working fine, showing traffic targets. Just cannot update firmware.

I did get mine to do the update today. Didn’t do anything different then yesterday. I left it on yesterday for a while before turning it off, so maybe during that time it got the update. The update menu was not ghosted today and it walked right through the steps without a problem. Maybe it just needed more time to do its thing.

Tonight I decided to delete the Flightbox app and reinstall it. After reinstalling the app everything went like clockwork and the firmware updated successfully. Thanks for an awesome product and great support!

I downloaded the new app. Updated my firmware no problems at all. Great job guys.

I successfully updated to 1.0r1 but, when I point my browser to, there is an Error banner that pops up saying, “You are running an old Stratux image that can’t be updated fully and is now deprecated. Visit https://www.openflightsolutions.com/flightbox/image-update-required for further information.”

I went to the image update tutorial and followed the instructions for re-imaging the micro SD card and everything is working fine and the error banner is now gone! Success!!!

I couldn’t update my image using the iPad retina app (update selection grayed out, nothing worked to fix that), so I decided to reimage. I followed all these steps, re-imaged the sd card, got the green and red lights, but the unit seems to be bricked.

When I reseated the card it worked to the extend that Foreflight shows a connected device. However, I’m not seeing a device name listed on the Foreflight map display.

This iPad came from the Apple refurb store. When I flew it with the older software I had this same issue. FF recognized as a device, but didn’t show a device name on the device screen, and didn’t show any targets or weather.

I’m flying this afternoon, I’ll let you know if it really works or not.

If the device is showing up in the ForeFlight “Devices” list, it isn’t bricked. You can confirm this by using the built-in web application. Open Safari and point it to - this will open the Status screen and you can see the number of UAT and 1090-ES messages the box is receiving.

ForeFlight has a bug (or a feature that I don’t understand) which causes the small overlay in the upper left-hand corner that indicates the number of ADS-B towers to appear and disappear at seemingly random points. You can usually get it to reappear by toggling the composite radar option on or off.