Updated Firmware, now FlightBox App crashes on stratux reconnect

[  ] FlightBox Kit
[  ] FlightBox Assembled (FB1X)
[ X ] Generic Stratux

FlightBox / Stratux version: 

Updated successfully from v0.8r2 to v1.0r1

FlightBox / Stratux build: 


Radio Configuration:
[ X ] Dual Band
[  ] Single Band - US / CA - 978 MHz UAT
[  ] Single Band - International - 1090-ES

GPS Configuration:
[  ] None - Using mobile device's GPS
[ X ] Open Flight Solutions Remote GPS
[  ] Internal GPS Module (VK-172)
[  ] Other:

USB Power Source:
[ X ] USB Battery: Anker 16000

EFB Application name and version:

FlightBox EFB

Please include a detailed description of your issue or question:

I launched the FlightBox App on my iOS 9 iPad while my Stratux was running 0.8r2. I saw that a firmware update was available, so I followed the instructions as described. After several minutes passed and it was clear the update was fine, I re-connected to my stratux wifi network and then launched the FlightBox app… CRASH after a few seconds. Relaunch - crash. I tried my phone, etc. If I am on my home wifi or wifi is disabled, the FlightBox app runs fine, but if I’m connected to my Stratux wifi network the app crashes.
Foreflight works fine when connected to stratux and I’m getting GPS, ADS-B, etc, no problem. The stratux webpage/app works fine. All is fine, except the FlightBox App.

I’ve restarted the stratux.
I’ve deleted / reinstalled the FlightBox App.
I’ve tried my iOS 10 iPhone 6.
According to the iOS App Store I have the latest version of the app.
All is fine, except the FlightBox App crashing whenever connected to stratux.

Are you on iOS 10 by any chance? I’ve not done any testing on 10 yet.

I tried originally with iOS 9 (lastest rev) on my iPad mini (current version) as well as iOS 10 on my iPhone 6. Same result. If I’m connected to the stratux WiFi network, the FlightBox app crashes a few seconds after launch, but if WiFi is connected to another network or off, the FlightBox app loads just fine.

Hmmm… I haven’t been able to reproduce a crash with the FlightBox firmware version 1.0r1 and any version of iOS. However, I have been able to reproduce a crash with the latest version of the Stratux firmware - it appears that some of the data structures being sent have changed. Are you running the official FlightBox build or the Stratux build?

Good / Interesting question. I was running the official Stratux build (0.8r2) when I opened the FlightBox app for the first time and it prompted me to update. It then updated (assume to Flightbox 1.0.r1 given the build/release version) and now the FlightBox app is unstable.

I can leave this build on the Stratux for a few days if you need help debugging (hopefully you’re getting crash logs through iTunes Connect?), but later this week I’ll manually flash the stratux, even though that seems to be running fine. Can you run a check on the build branch (Stratux vs FlightBox) and modify your ‘Update’ alert if you’re not running an official FlightBox build?

Quick update: I re-flashed the SD card with pi-filler (Mac) to the latest Stratux (not FlightBox) 1.0.r1 build, then relaunched the FlightBox App --> no crash.

Possible to implement a check at launch/before update if you’re running the Stratux vs FlightBox build (and restrict users from updating the Stratux builds until this is resolved)?