Setting AHRS Sensor Orientation calibration failed

In the GPS/AHRS page the Flightbox shows an unusual attitude. When I click ‘Reset AHRS’ it centers and immediately goes back to the unusual attitude.

When I try to ‘Set AHRS Sensor Orientation’ in ‘Settings’ I get a ‘Set AHRS Sensor Orientation: Failed!’ message. ‘There was an error: up and forward axes cannot be the same. The calibration failed.’

I’ve tried different orientation but I cannot figure out if I am doing something wrong or if it is something else. Can someone provide more detailed instructions or a video?

The GPS is working and if I move the box the attitude changes accordingly.


FlightBox Kit
FlightBox / Stratux version: ahrs0.4
FlightBox / Stratux build: 55ab2fc3e9

Radio Configuration:
[ x ] Dual Band

GPS Configuration:
[ x ] Other: AHRS/GPS/BARO board

USB Power Source:
[ x ] USB Battery: Anker PowerCore II 20000 Portable Charger, 20000mah Power Bank with 3 PowerIQ, 6A Output, Dual Input and 4A Fast Recharging (

USB Cable:
[ x ] 3’ heavy gauge cable included with FlightBox

EFB Application name and version: Fltplan Go


Here’s a link to the video that walks you through the orientation process:

Be sure you have the latest version of the firmware installed (0.5.1) and the Attitude Sensor and Altitude Sensor turned on in the Settings page. You can download the latest firmware from here.

Last time I tried FltPlan Go there was something off about their AHRS implementation. We’ve tested our side of it successfully with other EFB apps including WingX Pro, FlyQ EFB, and Aerovie, so I’m pretty sure the issue is on their side. You might contact their support and see if they have an update or fix. Let them know that I would be happy to help if they have any questions.

Thank for the video. I was doing it correctly but was not registering. I guess I was either not patient enough or was too smooth turning the box for the accelerometer to register a direction change. It did take me several times but I got it to pass the calibration.

To update the firmware I am not sure which file to download. The instructions talk about version and build values that looks like “Version 1.0r1 (d1607e0729)” or 0.8x. My version just read ‘Version ahrs0.4 (551b2fc3e9)’. There is no ‘x’ or no 1.0r1. Which one do I need?

Ok. I looked at the filenames and found the one with the verbose ‘ahrs0.5.1’. I downloaded it and successfully installed. Version now reads ‘Version: ahrs0.5.1 (fc438c0b30)’

Now the AHRS stopped working.

All the buttons below the AHRS display on the GPS/AHRS page are red. Moving the box does not change the attitude, pitch, roll. The Status page shows the box connected to GPS and the light is amber on the box. I also do not see the map showing the GPS location. What now?

I cycled the GPS, Attitude/Altitude Sensor buttons and was able to complete the AHRS Sensor Orientation step.

Got it. I hit CTRL F5 to refresh the page. All is working now. :grin:

The AHRS display on FltPlan GO is extremely sensitive an not true. A few degrees pitch or roll will flip the HSI. I am going to contact FltPlan Go to report that behavior.

The AHRS display using the Flightbox page on works well.