iOS 13 FlightBox Utility not connecting; EFB connects fine

Please provide the following information:

[  ] FlightBox Kit
[  ] FlightBox Assembled (FB1X)
[ X ] Generic Stratux

FlightBox / Stratux version: (e.g. "v0.8r2" or "v1.0r1")

FlightBox 2.0r1

FlightBox / Stratux build: (e.g. "db130aab76")

(not available at the moment)

Radio Configuration:
[ X ] Dual Band
[  ] Single Band - US / CA - 978 MHz UAT
[  ] Single Band - International - 1090-ES

GPS Configuration:
[ X ] None - Using mobile device's GPS
[  ] Open Flight Solutions Remote GPS
[  ] Internal GPS Module (VK-172)
[  ] Other:

USB Power Source:
[  ] USB Battery: (Make / Model Here)
[  ] Cigarette Lighter Adapter: (Make / Model Here)

Other: Hard-wired to aircraft power w/ circuit breaker

USB Cable:
[  ] 3' heavy gauge cable included with FlightBox
[  ] Other: (Make / Model / Description Here)

EFB Application name and version:

Current ForeFlight (11.8.1) running on iPad Pro 10.5, iOS 13.1.3

Please include a detailed description of your issue or question:

I’m unable to get the FlightBox utility app on my iOS 13 iPhone or iOS 13 iPad to connect to the Stratux box running 2.0r1. The box is sending ADS-B traffic and WX fine via wifi to ForeFlight on both of those devices and to my MGL EFIS via a serial wire.

I am able to connect to the box using the FlightBox utility app on an iPad still running iOS 12 (that’s how I verified FlightBox software 2.0r1 today) and with the generic Stratux app on the iOS 13 devices.

Is this a known issue? Any suggested workarounds (other than not updating the iOS 12 iPad)?


Did you ever get a fix for this? I’m having the same problem.

I haven’t gotten a fix yet, no. Thanks for posting - it’s helpful to see it’s not a unique issue.

Same here. Any response from Openflightsolutions?

In the Report page, I get the following Status Report message: ‘Attempting to connect with your FlightBox system. Make sure your mobile device is connected to the FlightBox wifi network.’

1 Like

I’m see the same behavior as well.

I did send in a support ticket about a week and a half ago. If or when I hear back, I will add the response here (unless it’s been posted on the thread already by that time).

Have you heard anything from support yet?

I haven’t heard anything yet, no.

Has anybody on this thread tried to re-image their FlightBox to see if that helps?

So is this issue with the newest IOS going to be address in 2020? I mean how long does this take???

I was having the same problem with a brand new iPad mini. I got mine to work by Settings, Privacy, Location Services on, FlightBox Utility, and then enable “always” or “while using the app”. It is working fine now.


Good catch! - thanks for posting. I will try this the next time I’m out at the airplane.

Thank you, Ricka18398 - this fixed it for me, too.

Thanks! That was it. Spent hours trying to sort this out. Thanks!

I just followed the suggestions by Ricka18398 and will let you know how I make out.

I have also been getting on the iPad that the wifi has no internet connection with the little explanation point symbol and then not seeing the wifi symbol next to the %battery, although the flightbox seems to be doing its thing. I’m running iPadOS 13.3.1 and FltPlanGo 4.7.24 I can’t tell which flightbox version etc. I have as I can’t link the utility. I do however think I have the latest firmware (fall 2018?) and the hardware would have been created in the fall of 2016

I had same problem. THanks for the fix. THe Ipad would pop up privacy settings, but it would vanish before I could answer. THanks all!