GPS INOP after installing AHRS


I just installed the AHRS upgrade kit. According to the iOS app from my telephone everything is working but the GPS indicates a gray dot which means INOP. However when I connect to the FlightBox WiFi via my iPad, and go to devices it reports “connected provides GPS and ADS-B.” But- when I go to the AHRS on the iPad and click on the GPS icon the GPS status reports “Source iOS.”

Also - FYI I took the flightBox outside for a few minutes and still no joy. One more point - the lights for “ADS-B, GPS & Power” under the light pipes are also INOP.

So - what do you think is going on and how can I resolve this?

Bret C

Same problem here, no fan and no leds.

1 Like


Does the iOS app show that you have GPS?

Did you update the software via the Web UI to the “AHRS Beta Build” as indicated on the status page, and do a hard reset (power cycle) afterwards? The new software is required to “see” the AHRS board. I am running a RPi-3 with the new AHRS board and all is fine here. The fan turns on at 40 degs C.

No GPS or AHRS data.(gray)
Every thing appears dead.
Firmware version v1.0r1.
UAT Data and Towers yellow everything else in the green.
Ipad Air, powered by Anker battery.

You must install the 11mb update file for AHRS board. File name is
You get it from the AHRS page under Software on the Web site.


It was my understanding the iOS application identifies the board, the latest firmware and automatically updates the FlightBox. The iOS app indicated that it had the most up to date firmware installed.

No. You have to use the Web server to update the firmware manually until the ios app is revised. Use the Web server to see everything. Updates are coming in the next few weeks according to Steve.

I re-imaged my card and updated the firmware.
The ADS-B app on the I-Pad still says version v1.0r1 but using computer with windows 10 connected to http://192-168.10.1 shows version v1.or1(d1067e729).
The leds now show the power led on (green), the GPS led blinking (red) and the ADS-B led blinks (blue).
Still no GPS fix and it only saw one sat.(outside for about 15 min. cold here too)
I removed the gps receiver that came with the flightbox and it worked fine.
Another question, I’m using FlyQ, will the AHRS work with it? Should have asked first I guess.

Added external antenna, gps ok now.
The old one worked without external antenna.

Please forgive my apparent computer ignorance. I have (tried) to follow these steps:

1.Download the BETA firmware update file from our web server [ here ].
2.Follow the manual update process using the web user interface detailed [ here ]. (The current FlightBox Utility app is not able to install beta firmware at this time.)
3.After the system has rebooted and your laptop / desktop has re-established a Wifi connection, you will need to do a hard reset (unplug power / reconnect power). A hard reset is required before the GPS on the board will be recognized.

I guess I don’t know how to access the FlightBox from my computer. Can someone please walk me through it?

With some embarrassment,


…OK. I followed the directions that were sent out today regarding the software install.
I finally got my computer to talk to the FlightBox. I installed the update as described and got the “success” pop-up.
I waited the necessary 60 seconds, re-connected with FlighBox and refreshed the page.
The software version still shows the old copy. Even after rebooting “Ctrl” F5 I still get the old version.
What did I do wrong?