FlightBox App not updating to Beta FWare

Please provide the following information:

[  ] FlightBox Kit
[ x ] FlightBox Assembled (FB1X)
[  ] Generic Stratux

FlightBox / Stratux version: v1.0r1 (cannot update to 1.3b3

FlightBox / Stratux build: (latest stable

Radio Configuration:
[ x ] Dual Band
[  ] Single Band - US / CA - 978 MHz UAT
[  ] Single Band - International - 1090-ES

GPS Configuration:
[  ] None - Using mobile device's GPS
[  ] Open Flight Solutions Remote GPS
[ x ] Internal GPS Module (VK-172)
[  ] Other:

USB Power Source:
[  ] USB Battery: (Make / Model Here)
[ x ] Cigarette Lighter Adapter: (supplied

USB Cable:
[ x ] 3' heavy gauge cable included with FlightBox
[  ] Other: (Make / Model / Description Here)

EFB Application name and version: irrelevant 

Please include a detailed description of your issue or question:

Flightbox app was saying I was running an older beta version, so I pressed the install latest beta firmware button, It said the unit would reboot but it never did. After five mins I forced a reboot from the settings page, but it was still showing the same beta version. So I decided to downgrade to latest stable and try going up to beta from there as that has worked in the past when I had issues. No joy, and to make matters worse it now appears that the update image path button on the settings web page from my laptop is missing, so I cannot manually upload the shell script to the unit.

Is there another way of getting access without reimaging? It’s a pain in the a$$ having to remove the board to get at the sd card.

Which version are you “stuck” on? I’ll install it and see if I can reproduce the issue.


No worries, I managed to get the box back onto the beta version. For some reason the browser on the Mac wasn’t clearing the cache with a forced page recycle in Safari so I pulled down Chrome and it worked.

I’ll go to the latest stable version when you release it.