FlightBox AHRS Issue in Accelerated environment

When I use the FlightBox with AHRS it seems to initially work, however if I am in an accelerated environment it will fail (Show incorrect attitude). In other words if I enter a steep turn the AHRS will initially follow the regular Gyro, however after a half turn or so (15- 20 seconds later) maintaining level flight (1.7G) it will right itself and show a upward pitch, which is incorrect. Am I doing something wrong or is this an inherent issue in an accelerated environment. I am using AVARE for the display, but that should not matter or does it…

Here’s a screenshot from today


I have flown my Flightview for 150 hours and have never seen what you have described. I do have to recalibrate often, with the latest upgrade. Pitch is usually 10 degrees off in level flight.

Send a trouble ticket to Steve.

Hi Ken,
I did contact Steve, he suggested it might be the Software (Avare), so I did another flight just using the Web interface, sure enough it worked a lot better (see image below). Even with that if the GPS reception is compromised then you might have incorrect Attitude in an accelerated environment as the sensor are set/reset based on GPS track. So my test is basically to sustain altitude in a Steep turn, thus exerting a little g-force which will ‘poison’ the algorithm. I noticed that the poisoned altitude got ‘corrected’ I am assuming that it was the GPS track that was responsible. What is important to note that the term Solid State Gyro is a true misnomer. This device is NOT a gyro it is a combination of a rate sensors (first derivative) and accelerometers (second derivative), therefore the data must be integrated to show attitude, thus any errors will also be integrated and must be slaved to something to nullify those errors. BTW your pitch error might be that you calibrate/reset your device while taxiing, in my plane that would automatically be a 10 degree pitch-up in flight.

Hi Peter,
Are you using the ethernet connection or Wi-Fi? I lost GPS reception on my Avare apped Samsung tablet when Steve hooked me up with the direct connection. I tested twice and went back to the Wi-Fi. I was in straight and level flight, so don’t know if I would have had your issue with the AHRS. I tried the direct connection because when I menued to the Flight Data Computer page I would get “kicked back” to the previous menu. I have solved this issue by opening FlightView until it is fully up, then swipe it off the iPad, and open it again. I do it on the ground because the flight log gets screwed up when flying. I only configure when flying, it is getting more stable with each flight.