Firmware Update not installing through utility app


I haven’t been an active pilot for about 3 years. I’m getting current this week and am trying to get my FlightBox back up and running. Everything is working fine and connecting fine, but the Utilities app says I need a firmware update. I’m running v1.0r1.

I know I have the latest Utilities app because I just downloaded it. When I choose the “Install Firmware Update” it runs me through the two pop ups, which I “ok” each time. Then it disconnects my iPad from the FlightBox wifi (within about 5 seconds). But the FlightBox never reboots. It just keeps running. When I reconnect to the Flightbox wifi, the app says I need to install the update still.

What do I need to do to get the update to install from the app? I’ve tried unplugging the Flightbox to force a reboot before doing the install. No luck.

I also tried a manual update, but the link to the page where I need to download the update is returning a 404 page.

Thanks in advance for any help!


Taking a stab at the problem myself, I think the process of installing the new firmware is working fine. I think the current stable version of the firmware is not where it is supposed to be online, so my box tries to install and fails. That’s just a guess based on the fact that when I go to the directory for the website where the file should reside, it isn’t there.